Task Server not creating Excel Report attachment  [SOLVED]

Discuss your general Proclaim related queries here.
Boonerball
Posts: 3
Joined: Tue May 01, 2018 2:16 pm

Task Server not creating Excel Report attachment

Post by Boonerball »

Hi,

I have searched high and low on this one.

I have a scheduled report on a task server and it runs fine and log shows processed. However, the report is not in reports folder and does not attach to the email that gets sent.

Worked a few weeks back and no obvious changes.

Run from Advanced Reports Execution in same session it works fine. The list in Advanced Report Execution history shows the manual report and the scheduled reports but only the manual report will open.

Run the report in Advanced Report Execution as 'scheduled asap' still no report appears.

Allow VBA ticked in Macro settings and Outlook is open and Excel is on same server as task server.

Excel is how the original report was created and data preferences on the task server show the report to be created in Excel.

I am stuck.

David P
Posts: 82
Joined: Thu Jan 11, 2018 10:33 am
Has thanked: 8 times
Been thanked: 11 times

Re: Task Server not creating Excel Report attachment

Post by David P »

Are the parameters still correct on the task?
If so I'd remove it and the recreate a fresh version.

Boonerball
Posts: 3
Joined: Tue May 01, 2018 2:16 pm

Re: Task Server not creating Excel Report attachment

Post by Boonerball »

I have tried recreating and all parameters are correct.

Ticked VBA access in trust settings

Server memory check when it runs.

Save directory path is correct.

Created a separate job.

Ran in same session on advanced report execution and as a scheduled report and same happens.

Sent as pdf no problem.

Run report manually no problem.

revellbikes
Posts: 488
Joined: Fri Jun 15, 2012 12:44 pm
Has thanked: 16 times
Been thanked: 51 times

Re: Task Server not creating Excel Report attachment

Post by revellbikes »

Are you running this from the Task Server? If so, have you definitely got 'Email Attach file' option set to true on the Data tab within Task Server Admin?

Screenshot_1.png
Screenshot_1.png (1.49 KiB) Viewed 232 times

I've also found you must select 'Report parameters' and click OK, even if there are no parameters, this seems to select the default report output which is otherwise undefined.

Boonerball
Posts: 3
Joined: Tue May 01, 2018 2:16 pm

Re: Task Server not creating Excel Report attachment  [SOLVED]

Post by Boonerball »

Solution was two change two parameters and save on the data tab on the Advanced report in TS scheduled tasks. This cleared the issue and is a known but rare bug in OpenEdge and Proclaim.